xcode-select: error: tool ‘xcodebuild’ requires Xcode, but active developer directory

Mac

事象

brewのupgradeをしたら妙なエラーに遭遇。

$ brew upgrade blueutil
(中略)
xcode-select: error: tool 'xcodebuild' requires Xcode, but active developer directory '/Library/Developer/CommandLineTools' is a command line tools instance

Do not report this issue to Homebrew/brew or Homebrew/core!

対応

Xcodeを起動してみるとよくわからないダイアログ。

Install additional required components?
Xcode requres additional components to support running and debugging. Choose Install to add required components.

「Install」を押してみたが、よくわからないエラー。

Intalling Compnents...
An unknown error occurred. See the install log for more details.

以下のコマンドを実行したら解決した。

$ sudo xcode-select -r

現在10.13.6 High Sierra。そろそろ限界かも。


【参考サイト】

macOS High SierraにXCode 10.1をインストール(備忘録) - Qiita
macOS High SierraにXCodeをインストールする。 XCode 10.1のインストール 2020年1月時点で最新のXCode11はインストールできない。XCode10.1をAppStoreではなく、Develop...